Hi…

Kali ini kita akan mencoba failover dengan menggunakan recursive gateway. Salah satu alternatif metode failover selain menggunakan scripts, yang pernah dibahas pada artikel sebelumnya. Berikut topologi nya :

Kita buat dulu 2 buah default route di router dengan gateway ke koneksi “MAIN” dan “BACKUP”.

Selanjut nya, ubah default route koneksi “MAIN” dengan gateway 192.168.88.1 menjadi gateway 8.8.8.8 dengan scope 30 dan target scope 30

Selanjutnya tambahkan rule routing baru dengan dst.address 8.8.8.8 dengan gateway 192.168.88.1 agar dapat menjadi recursive gateway

Jika dilihat dari rule nya, mungkin rule diatas tidak sesuai standar penentuan gateway, karena menggunakan 8.8.8.8 sebagai gateway, namun dengan target-scope=30 rule tersebut bisa melakukan lookup ke rule lain yang memiliki nilai scope ≤ 30 sehingga menjadi recursive gateway. Sehingga hasilnya menjadi seperti berikut

Apabila koneksi “Main” down maka akan otomatis pindah ke “BackUp”

Berikut hasil trace route di Laptop pada saat koneksi “Main” up dan down

Dengan demikian, check-gateway dapat melakukan pemantauan ke IP 8.8.8.8 yang pada rule tersebut seolah-olah menjadi gateway langsung. Sehingga ketika check-gateway gagal melakukan PING ke 8.8.8.8 maka gateway internet akan dialihkan ke link backup.

Sebagai catatan, mekanisme ini hanya untuk membantu check-gateway melakukan pemantauan link, sedangkan jika dilakukan traceroute traffic aslinya tetap melewati link / gateway ISP.

Berikut konfigurasi lengkapnya

/ip address
add address=192.168.88.254/24 interface=ether1 network=192.168.88.0
add address=192.168.89.254/24 interface=ether2 network=192.168.89.0
add address=192.168.90.254/24 interface=ether5 network=192.168.90.0
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1 src-address=\
 192.168.90.0/24
add action=masquerade chain=srcnat out-interface=ether2 src-address=\
 192.168.90.0/24
/ip route
add check-gateway=ping comment=Main distance=1 gateway=8.8.8.8 target-scope=\
 30
add comment=BackUp distance=1 gateway=192.168.89.1
add check-gateway=ping distance=1 dst-address=8.8.8.8/32 gateway=192.168.88.1

 

2 thoughts on “Failover dengan Recursive Gateway pada MikroTik”
  1. Min, Saya ada dua koneksi, satu ip publik dan satu PPoE. Saya ingin buat Failover seperti ini, sudah jalan sih namun gak bisa browsing karena dari ISP ke 2 mewajibkan DNS Mereka dan tidak bisa pakai dns lain untuk browsing. Klw ping lewat winbox sih TTL, ada solusi min ? thanks

Leave a Reply

Your email address will not be published. Required fields are marked *