Hi…

Kali ini kita akan mencoba menggunakan fitur queue tree di MikroTik untuk melimit bandwidth, baik upload maupun download. Pada lab kali ini, ada 3 IP yang akan dicoba dilimit, pada praktek riil nya, bisa juga menggunakan satu blok subnet untuk melimit bandwidthnya.

Ok, langsung saja ya……

Pertama buat dulu mark connection di IP Firewall Mangle, karena kita akan membatasi upload dan download, maka mark connection nya dibuat masing-masing.

/ip firewall mangle
add action=mark-connection chain=forward comment="Mark Connection Upload" \
 new-connection-mark=Client1-Upload passthrough=yes src-address=\
 192.168.88.11
add action=mark-connection chain=forward new-connection-mark=Client3-Upload \
 passthrough=yes src-address=192.168.88.13
add action=mark-connection chain=forward new-connection-mark=Client2-Upload \
 passthrough=yes src-address=192.168.88.12
add action=mark-connection chain=forward comment="Mark Connection Download" \
 dst-address=192.168.88.11 new-connection-mark=Client1-Download \
 passthrough=yes
add action=mark-connection chain=forward dst-address=192.168.88.12 \
 new-connection-mark=Client2-Download passthrough=yes
add action=mark-connection chain=forward dst-address=192.168.88.13 \
 new-connection-mark=Client3-Download passthrough=yes
add action=mark-packet chain=forward comment="Mark Packet Upload" \
 connection-mark=Client1-Upload new-packet-mark=Client1-Packet-Upload \
 passthrough=yes
add action=mark-packet chain=forward connection-mark=Client2-Upload \
 new-packet-mark=Client2-Packet-Upload passthrough=yes
add action=mark-packet chain=forward connection-mark=Client3-Upload \
 new-packet-mark=Client3-Packet-Upload passthrough=yes
add action=mark-packet chain=forward comment="Mark Packet Download" \
 connection-mark=Client1-Download new-packet-mark=Client1-Packet-Download \
 passthrough=yes
add action=mark-packet chain=forward connection-mark=Client2-Download \
 new-packet-mark=Client2-Packet-Download passthrough=yes
add action=mark-packet chain=forward connection-mark=Client3-Download \
 new-packet-mark=Client3-Packet-Download passthrough=yes

 

Setelah itu, buat queue tree. Karena queue tree ini bersifat hirarki, dimana ada parent untuk queue, maka jangan sampai salah menempatkan parentnya

/queue tree
add name=Global_Queue parent=global
add name=queue_upload parent=Global_Queue
add limit-at=1M max-limit=2M name=queue_client1_upload packet-mark=\
 Client1-Packet-Upload parent=queue_upload
add limit-at=2M max-limit=3M name=queue_client2_upload packet-mark=\
 Client2-Packet-Upload parent=queue_upload
add limit-at=3M max-limit=4M name=queue_client3_upload packet-mark=\
 Client3-Packet-Upload parent=queue_upload
add name=queue_download parent=Global_Queue
add limit-at=1M max-limit=2M name=queue_client1_download packet-mark=\
 Client1-Packet-Download parent=queue_download
add limit-at=2M max-limit=3M name=queue_client2_download packet-mark=\
 Client2-Packet-Download parent=queue_download
add limit-at=3M max-limit=4M name=queue_client3_download packet-mark=\
 Client3-Packet-Download parent=queue_download

Terakhir, silahkan coba speedtest

Pada IP 192.168.88.11

Pada IP 192.168.88.12

Pada IP 192.168.88.13

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *