Hi…

Kali ini kita kan coba pppoe server dan client di mikrotik. Topologinya kira-kira seperti ini

Ok,, lanjut aja ya. Disini saya tidak akan menjelaskan detail awal seting mikrotik, karena saya rasa pembaca sudah mengetahui konfigurasi dasar mikrotik. Jadi kita langsung saja ya.

Oh ya… syarat untuk bisa konfigurasi PPPoE ini adalah sudah ada koneksi/hubungan antara server dan client, karena PPPoE ini nantinya akan berjalan diatas koneksi yang sudah ada tersebut. Dan dilab ini koneksi melalui ether1 masing-masing Router.

Pertama buat dulu service PPPoE server nya, kira-kira seperti berikut. Untuk profile nya bisa buat profile sendiri (custom) sesuai kebutuhan, tapi disini saya menggunakan profile default

Selanjutnya adalah buat user dan password di tab secret. User ini lah nanti sebagai client PPPoE. Kemudian, isikan ip Local (IP PPPoE Server) dan Remote (IP PPPoE Client). IP ini akan menjadi alamat point to point PPPoE nya

Sekarang kita beralih ke R2 atau Router client. Menuju ke menu PPP, pilih tambah interface PPPoE Client

Pilih interface, dimana koneksi antara R1 dan R2 sudah berjalan.

Selanjutnya, pindah ke tab dial out, isikan user dan pass yang sesuai dengan R1 (PPPoE server). Dan apabila ingin menggunakan interface pppoe client ini untuk koneksi internet, cek list pada add default route. Selanjutnya klik Ok, untuk menyimpan konfigurasi.

Cek pada PPPoE server, koneksi pppoe sudah berjalan

Terakhir, cek koneksi internet pada laptop-client

Berikut script nya

R1

/interface pppoe-server server
add disabled=no interface=ether1 service-name=pppoe1
/ip address
add address=192.168.88.1/24 interface=ether1 network=192.168.88.0
add address=192.168.43.5/24 interface=wlan1 network=192.168.43.0
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan1
/ip route
add distance=1 gateway=192.168.43.1
/ppp secret
add local-address=10.0.0.1 name=user1 password=12345 remote-address=10.0.0.2 \
 service=pppoe

R2

/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 \
 password=12345 user=user1
/ip pool
add name=dhcp_pool0 ranges=192.168.89.2-192.168.89.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether2 name=dhcp1
/ip address
add address=192.168.88.2/24 interface=ether1 network=192.168.88.0
add address=192.168.89.1/24 interface=ether2 network=192.168.89.0
/ip dhcp-server network
add address=192.168.89.0/24 gateway=192.168.89.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1

Ok, sekian dulu lab kali ini, terima kasih

Leave a Reply

Your email address will not be published. Required fields are marked *